Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 12, 2025 - 11:00 UTC
Update
Please note that the maintenance schedule has been updated. Kindly check the new start time below.
Posted Nov 04, 2025 - 07:45 UTC
Scheduled
We want to inform you about upcoming scheduled maintenance. During this period, you may experience brief difficulties accessing the BackOffice Frontend Application, including possible temporary logouts from your account. There may be no service interruptions, but any interruptions are expected to last up to 10 minutes. We appreciate your understanding as we work to enhance our services.
Posted Oct 31, 2025 - 16:15 UTC
This scheduled maintenance affected: Transaction Processing (Deposits with exchange, Deposits w/o exchange, Withdrawals with exchange, Withdrawals w/o exchange, Exchanges, Invoices with exchange, Invoices w/o exchange) and Payment Gateway Applications (BackOffice - Frontend, API Servers).